The PeopleSoft Student System will not open for some users from the Staff Portal link
Incident Report for City University of Seattle
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 21:21 PST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Dec 06, 2023 - 12:09 PST
Investigating
Some users may not be able to access the PS Student System from the Staff Portal link. It will just spin and never open. We are currently investigating the issue. For a workaround try this link, click on the Campus & Student Admin option, then click on the CityU logo. https://nus.soar.cci.nu.edu/
Posted Nov 07, 2023 - 08:41 PST
This incident affected: Peoplesoft.