Peoplesoft Outage

Incident Report for City University of Seattle

Postmortem

The Peoplesoft application servers had to be restarted following the SAML certificate rollover.

Posted Aug 17, 2026 - 11:06 PDT

Resolved

This incident has been resolved.
Posted Aug 17, 2026 - 11:05 PDT

Identified

Sign-in loop following SAML certificate update.
Posted Aug 17, 2026 - 09:58 PDT
This incident affected: Peoplesoft.