Unable to download excel files from PeopleSoft
Incident Report for City University of Seattle
Resolved
This incident has been resolved.
Posted Jan 26, 2024 - 21:21 PST
Monitoring
If you are experiencing this issue, please contact the CityU Helpdesk for a workaround.
Posted Dec 13, 2023 - 17:05 PST
Identified
The issue has been identified as being related to a recent Windows update. If you are experiencing this issue, please contact the CityU Helpdesk.
Posted Dec 13, 2023 - 13:23 PST
Investigating
We are currently investigating this issue.
Posted Dec 13, 2023 - 10:52 PST
This incident affected: Peoplesoft.